Installing Ruby On Rails on Mac 10.10 is a pain

I’ve tried many “howto install Ruby” and “how to install Rails”, at the end the only installation method that works on Mac 10.10 (Yosemite) is this: Setup Ruby On Rails on Mac OS X 10.10 Yosemite

What to say? Installation went “ok” on Windows (this is not very true since I actually have Windows at work, and at work I have a proxy, so … I had to play a little bit), but on my Mac I have found something like 3000 tutorials on how to install this and that, and no tutorial was similar to others. Thanks to the author!

Then I had a lot of warnings that I’m trying to fix, and mostly I go on Stack Overflow to understand what’s happening. One of this errors is:

/usr/local/rvm/gems/[email protected]/gems/bundler-1.9.1/lib/bundler/shared_helpers.rb:83: 
warning: Insecure world writable dir /usr/local in PATH, mode 040777

For what I understood, you have this problem because anyone can write in /usr/local . So the fix was to digit the following command:

chmod go-w /usr/local

You can also have the same error referred to other directories, just launch this command with the appropriate path.

And now I’m having this other problem, unfortunately Stack Overflow does not have any ideas on how to solve it:

/usr/local/rvm/gems/ruby-1.9.3-p194/gems/activesupport-3.2.8/lib/active_support/values/time_zone.rb:270: 
warning: circular argument reference - now

Can anybody help me?

Related Posts: